Get in touch
Back
Maintenance

Flow builder maintenance

Completed 15 Nov at 01:15am IST.

Outbound webhooks service
Completed

Maintenance completed

Posted 15 Nov at 01:15am IST.
Started

Upgrading servers

Posted 15 Nov at 12:38am IST.