Get in touch
Back
Maintenance

Limekit and outbound servers maintenance

Completed 16 Nov at 01:00am IST.

Limekit Outbound UI
Completed

Maintenance completed

Posted 16 Nov at 01:00am IST.
Started

We'll be migrating our servers to more robust ones

Posted 16 Nov at 12:00am IST.